Wielopoziomowe formuły sumujące i warunkowe

CiRZ_1_27.jpg

Każdy użytkownik Excela zna na pewno formułę SUMA(), nie każdy jednak zna inne formuły sumujące. Czasami niezbędne jest dodanie wartości według wybranych parametrów albo zbudowanie wzoru, który pokaże nam, czy dane w tabeli spełniają wyznaczone kryteria. Warto zapoznać się z kilkoma bardzo użytecznymi formułami, które uproszczą dodawanie wybranych danych albo ich selekcję.

Przedstawione przykłady oparto na sprawozdaniu Grupy CD PROJEKT, które można znaleźć na stronie: https://www.cdprojekt.com/pl/typ-informacji-prasowej/year

SUMA()

Chyba najczęściej używaną formułą w Excelu jest zwykła SUMA(), która pozwala dodać liczby w podanym zakresie. Oczywiste jest zapisanie jej w postaci =SUMA(A1:A5), żeby dodać wartości znajdujące się w komórkach od A1 do A5. Warto jednak pamiętać, że formuła ta doda także liczby niesąsiadujące ze sobą, niezależnie, czy chcemy dodać wybrany zakres komórek, czy pojedyncze wartości. Wystarczy, żeby w nawiasie formuły wskazać kilka elementów, które chcemy zsumować rozdzielone znakami średnika; natomiast wybrany zakres komórek podać jako rozdzielany dwukropkiem, np. A1:A5.

Przykładowe zsumowanie kilku niesąsiadujących zakresów pokazuje rys. 1.

SUMA.JEŻELI()

Gdyby chcieć dodać wartości, które spełniają jakieś konkretne kryterium, warto zastosować formułę SUMA.JEŻELI(). Konstrukcja tej formuły zbudowana jest w następujący sposób: w pierwszej kolejności wskazujemy zakres (czyli obszar zawierający kryteria, które będą brane pod uwagę przy wykonaniu działania), następnie wpisujemy kryterium (jeśli jest to wartość tekstowa, to musi być wpisana w cudzysłowie) lub wskazujemy odwołanie do komórki, w której to kryterium występuje, na koniec podajemy zakres sumy (obszar, w którym znajdują się wartości liczbowe, które mają być dodawane). Przykład użycia tej formuły pokazano na rysunku 2.

Dostęp możliwy dla zalogowanych użytkowników serwisu. Jeśli posiadasz aktywną prenumeratę przejdź do LOGOWANIA. Jeśli nie jesteś jeszcze naszym Czytelnikiem wybierz najkorzystniejszy WARIANT PRENUMERATY.

Zaloguj Zamów prenumeratę
Drukuj

Zobacz również

Archiwum

Polecamy